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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to model simple heat pipes and an active heat sink using Ansys Ice-
pak.

This chapter contains the following topic:
l "Sample Project - The Heat Pipe" below
l Open the Project

Sample Project - The Heat Pipe
Heat-pipes are used to transport heat from a heat source area, where there is limited space for
heat dissipation, to a place where it can be dissipated more easily. The objective of this exercise
is not to model the detailed physics inside a heat pipe. Instead, you will model a heat pipe by
using a series of cylindrical solid blocks that connect the heat source to an air-cooled heat sink.
These blocks will have an anisotropic conductivity with a very large conductivity in the pipe axis
direction along which the heat is carried away. The model will be constructed using the default
metric unit system. You will also make use of nested non-conformal meshing using mesh
regions to reduce the cell count in the model.

This tutorial demonstrates how to model simple heat pipes and an active heat sink using ANSYS
Icepak. In this tutorial, you will learn how to:

l Create anisotropic solid materials.
l Assign materials to simulate a simplified heat-pipe in a system.
l Assign nested non-conformal mesh regions.
l Add a solution setup and run the simulation.
l Create temperature and velocity vector field plots.

Getting Started with Icepak®: Heat Pipe Model
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Figure 1-1: Heat Pipe

Open the Project
This chapter contains the following topics:

l Launch the Ansys Electronics Desktop

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the
application is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Introduction 1-2
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples.
2. Double-click the Icepak folder and then the Heat Pipe Model folder.
3.  Select the file Heat_Pipe_Model.aedt and clickOpen.
4. The model is displayed in the 3D Modeler window.

Introduction 1-3
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5. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.
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2 - Create and Assign Materials
Create anisotropic materials to have very high conductivity in the pipe heat removal directions
but normal conductivity in the other directions.

Create Anisotropic Materials
1. From the Toolsmenu, select Edit Libraries >Materials.
2. In the Edit Libraries dialog box, click Add Material.
3. In the View/Edit Material dialog box, define the following material properties:

l Thermal Conductivity: Anisotropic
l T(1,1):20000*1.0 
l T(2,2): 20000*0.005
l T(3,3): 20000*0.005
l Mass Density: 1 kg/m^3
l Specific Heat: 1 J/kg-C

4. Click OK.
5. Repeat steps 1 through 4 using the following conductivity tensor values:

l T(1,1): 20000*0.005
l T(2,2): 20000*1.0
l T(3,3): 20000*0.005

6. Repeat steps 1 through 4 using the following conductivity tensor values:
l T(1,1): 20000*1.0
l T(2,2): 20000*1.0
l T(3,3): 20000*0.005

Assign the Materials
1. In the History tree, expandModel > Solids > Al-Extruded.
2. Press and hold the Ctrtl key and select pipe1 and pipe2.
3. Right-click and select Assign Material.
4. In the Select Definition dialog box, selectMaterial1.
5. ClickOK.
6. In the History tree, select pipe3.
7. Right-click and select Assign Material.
8. In the Select Definition dialog box, selectMaterial2.
9. ClickOK.

Getting Started with Icepak®: Heat Pipe Model
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10. In the History tree, select Joint1 and Joint2.
11. Right-click and select Assign Material.
12. In the Select Definition dialog box, selectMaterial3.
13. ClickOK.
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3 - Assign Boundary Conditions
Assign a Block

1. In the History tree, expandModel > Solids.
2. Right-click block_1 and select Assign Thermal > Block.
3. In the Block Thermal Model dialog box, enter a Total Power of 25 W.
4. Click OK.

Assign a Grille
1. In the History tree, expand HS_vent_fan_asy > Vent_asy > Sheets > Unassigned.
2. Right-click vent_1 and select Assign Thermal > Grille.
3. In theGrille Thermal Model dialog box, enter a Free Area Ratio of 0.8.
4. Click OK.

Getting Started with Icepak®: Heat Pipe Model
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4 - Assign Mesh Regions
In this exercise, our goal is to reduce the overall cell count to a reasonable level while retaining a
good cell resolution within the model, especially where the velocity and temperature gradients
are higher. This model contains mesh regions assigned to non-model box geometry created for
the purpose of creating refined mesh. Assign a mesh region to mesh regions to each box sur-
rounding the fan, heat sink, and vent. Then, assign an outer mesh region to the box encom-
passing the other mesh regions.

Note: You can also assign mesh regions directly to model geometry.

Assign a Mesh Region to the Fan
1. In the History tree, expandModel > HS_vent_fan_asy > Fan_asy > Solids > Non

Model.
2. Right-click Fan_asy_mr1 and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog boxGeneral tab, enter a Name.
5. On the Advanced tab, enable User specified and define theMaximum Element Size

values:
l X: 0.025 meter
l Y: 0.025 meter
l Z: 0.025 meter

6. Define theMinimum Gap values:
l X: 0.001 meter
l Y: 0.001 meter
l Z: 0.001 meter

7. Define the followingMesh Parameters:
l Min. elements in gap: 2
l Min. elements on edge: 1
l Max size ratio: 5

8. UnderMulti-level meshing, deselect Enable to disable multi-level meshing.

Getting Started with Icepak®: Heat Pipe Model
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9. Click OK.

Assign a Mesh Region to the Heat Sink
1. In the History tree, expandModel > HS_vent_fan_asy > Heatsink_asy > Solids > Non

Model.
2. Right-click Heatsink_asy_mr1 and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog boxGeneral tab, enter a Name.
5. On the Advanced tab, enable User specified and define theMaximum Element Size

values:

Assign Mesh Regions 4-2
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l X: 0.025 meter
l Y: 0.025 meter
l Z: 0.025 meter

6. Define theMinimum Gap values:
l X: 0.001 meter
l Y: 0.001 meter
l Z: 0.001 meter

7. Define the followingMesh Parameters:
l Min. elements in gap: 2
l Min. elements on edge: 1
l Max size ratio: 5

8. UnderMulti-level meshing, deselect Enable to disable multi-level meshing.
9. Click OK.

Assign a Mesh Region to the Vent
1. In the History tree, expandModel > HS_vent_fan_asy > Vent_asy > Solids > Non

Model.
2. Right-click Vent_asy_mr1 and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog boxGeneral tab, enter a Name.
5. On the Advanced tab, enable User specified and define theMaximum Element Size

values:
l X: 0.025 meter
l Y: 0.025 meter
l Z: 0.025 meter

6. Define theMinimum Gap values:
l X: 0.001 meter
l Y: 0.001 meter
l Z: 0.001 meter

7. Define the followingMesh Parameters:
l Min. elements in gap: 2
l Min. elements on edge: 1
l Max size ratio: 5

8. UnderMulti-level meshing, deselect Enable to disable multi-level meshing.
9. Click OK.

Assign Mesh Regions 4-3

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Heat Pipe Model

Assign an Outer Mesh Region
1. In the History tree, expandModel > HS_vent_fan_asy > Solids > Non Model.
2. Right-click HS_vent_fan_asy_mr1 and select Assign Mesh Region.
3. In the SubRegion dialog box, clickOK to close the dialog box without adding padding.
4. In theMesh Region dialog boxGeneral tab, enter a Name.
5. On the Advanced tab, enable User specified and define theMaximum Element Size

values:
l X: 0.025 meter
l Y: 0.025 meter
l Z: 0.025 meter

6. Define theMinimum Gap values:
l X: 0.001 meter
l Y: 0.001 meter
l Z: 0.001 meter

7. Define the followingMesh Parameters:
l Min. elements in gap: 2
l Min. elements on edge: 1
l Max size ratio: 5

8. UnderMulti-level meshing, deselect Enable to disable multi-level meshing.
9. Click OK.
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5 - Assign Monitors
Create a Thermal Monitor
Create a thermal monitor to measure the temperature of block_1.

1. In the History tree, right-click on the block_1 object and select Assign Monitor > Point.
TheMonitor Setup dialog box appears.

2. In theMonitor Setup dialog box, enter a Name.
3. Under Thermal, select the Temperature check box.
4. ClickOK.

Create a Flow Monitor
Create a flow monitor to measure the speed of the flow through the vent.

Getting Started with Icepak®: Heat Pipe Model
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1. In the History tree, right-click on the vent_1object and select Assign Monitor > Point.

2. In theMonitor Setup dialog box, enter a Name.
3. Under Flow, select the Speed check box.
4. ClickOK.
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6 - Add a Solution Setup
Prior to generating a mesh, you must create a solution setup, in which you specify general and
solution settings.

1. In the Project Manager, right-click on Analysis and select Add Solution Setup.

2. On theGeneral tab, enter aMaximum Number of Iterations of 200.
3. In the Icepak Solve Setup Dialog under Flow Regime, select Turbulent and click

Options.

Getting Started with Icepak®: Heat Pipe Model
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4. In the Turbulent Flow Model dialog box, retain the default selection of Zero Equation
and clickOK.

5. On the Solver Settings tab, enter -0.1 as the Z Velocity initialization and retain the unit
m_per_sec.

6. ClickOK to save the settings. The solution setup is added under Analysis in the Project
Manager.

7. From the Filemenu, click Save.

Add a Solution Setup 6-2
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7 - Run the Icepak Simulation
1. In the Project Manager under Analysis, right-click Setup1 and select Analyze.
2. Right-click on Setup1 again and select Residual to open the Solutions dialog box, where

you can view the solution residuals as they are updated with each iteration.

Figure 7-1: Solutions Dialog Box - Residual tab

3. Click the Thermal Monitor tab and review the thermal monitor data.
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Figure 7-2: Solutions Dialog Box - Thermal Monitor tab

4. Click the Flow Monitor tab and review the flow monitor data.

Run the Icepak Simulation 7-2
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Figure 7-3: Solutions Dialog Box - Flow Monitor tab

5. Click Close.

Run the Icepak Simulation 7-3
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8 - Post-process the Icepak Simulation
Create a Temperature Field Plot

1. In the History tree, right-clickModel and select Select All.
2. Press the Ctrl key and click on each of the following pieces of geometry to deselect them:

l HS_vent_fan_asy > Fan_asy > fan_1_1 > Sheets > Unassigned > fan_1_Hub
l HS_vent_fan_asy > Fan_asy > fan_1_1 > Sheets > Unassigned > fan_1_Passage
l HS_vent_fan_asy > Fan_asy> Solids > Non Model > Fan_asy_mr1
l HS_vent_fan_asy > Heatsink_asy> Solids > Non Model > Heatsink_asy_mr1
l HS_vent_fan_asy > Vent_asy> Solids > Non Model > Vent_asy_mr1
l HS_vent_fan_asy > Vent_asy> Sheets > Grille > vent_1
l HS_vent_fan_asy > Solids > Non Model > HS_fan_vent_asy_mr1
l Solids > air > Region

3. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-
perature.

4. In the Create Field Plot dialog box, retain the default selections underQuantity and
In Volume.

5. Select the Plot on surface only check box.
6. Click Done.

Getting Started with Icepak®: Heat Pipe Model
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Figure 8-1: Temperature Field Plot

Create a Velocity Vector Plot
1. In the Project Manager, expand Field Overlays > Temperature.
2. Right-click Temperature1 and select Plot Visibility to hide the temperature field plot.
3. In the history tree, expand Planes and select the cut_1_plane.
4. In the 3D Modeler window, right-click and select Plot Fields > Velocity > Velocity Vect-

ors.
5. In the Create Field Plot dialog box, retain the default selection of Velocity underQuant-

ity and click Done. Velocity vectors are displayed on the plane.

Figure 8-2: Velocity vectors on a plane
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9 - Additional Exercise
For more experience with this heat pipe model, refer to Getting Started with Icepak - Transient
Simulation. This guides you through the following tasks:

l Selecting the Transient solution type
l Reviewing a dataset
l Assigning a piecewise linear transient power to a block boundary condition
l Reviewing transient solve setup options
l Monitoring a transient simulation
l Post-processing transient simulation results
l Selecting the Transient solution type
l Reviewing a dataset
l Assigning a piecewise linear transient power to a block boundary condition
l Reviewing transient solve setup options
l Monitoring a transient simulation
l Post-processing transient simulation results

Getting Started with Icepak®: Heat Pipe Model
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